Project

General

Profile

ATX powersupply and Led Node gives coil whine?

Added by WilcoE over 1 year ago

Hi,

i'm busy with converting my fish tank to Led lighting, and got 2 Jeenode Led with both 10 meters of rgb ledstrip 5050.
Everything works perfect only i got a high pitch sound from the ATX power supply (Zalman ZM460-APS) when i connect my led strips direct to the power supply everything is good. The high pitch sound from the supply is only with Jeenode Led

is there a fix for this? i know its not JeeNode problem... but because of all the smart people here :) i think... maybe i can ask them.

The high pitch sound (coil whine?) has something todo with PWM


Replies (3)

RE: ATX powersupply and Led Node gives coil whine? - Added by martynj over 1 year ago

@WilcoE,

The current drawn by the LED Nodes will have a strong component at the PWM frequency. ATX supplies (themselves switchers) are good at handling variable loads since that is what motherboards present. However, motherboards have several capacitors across the supply lines to satisfy very short-term peaks locally, then they get 'topped up' a fraction later by the main supply.

You could try similar by installing a large value capacitor at the JeeNode end of the connecting cable, say 470uf in parallel with 0.1uf
If this helps, then you can experimant with different capacitor values and for final use, select one that has a low ESR and sufficient ripple current capacity.

There may be a series L inside the ATX supply for filtering - these can by audible if the current is changing with a regular pattern due to the magnetostrictive effect. It could be removed without serious effect (your LED strips are radiating much more EMI noise than this is reducing). Please be cautious if you attempt this though - there are LETHAL voltages present inside that box, often for many seconds even after the mains cable is disconnected.

An alternative might be to move the PWM frequency out of the audio range (but the neighbourhood dogs might complain).

RE: ATX powersupply and Led Node gives coil whine? - Added by WilcoE over 1 year ago

Hi Martynj,

470uf / lower or higher didnt work also a 0.1uf didnt more harm then good (more pitch sound)

Maybe its better to buy a new power supply for this project :)
Thanks for your answers

RE: ATX powersupply and Led Node gives coil whine? - Added by WilcoE over 1 year ago

but... its always nice to know a fix for this :)

    (1-3/3)