Project

General

Profile

Resolving Windows driver issues talking to the BUB

Added by martynj 4 months ago

A recent problem with getting a PC to talk sensibly to a BUB II was resistant to resolution. With a jumper wire between TX & RX on the output side of the BUB, LED activity matched keystrokes input to a terminal emulator attached to the new COMXX port that showed up during enumeration, but nothing useful was echoed. This eliminated the common problem of mistakenly using a 'charger only' USB cable (not enough wires inside) and a lot on the BUB needs to be working for enumeration to succeed. So was this a faulty BUB assembly?

After some debugging (checking jumper settings for the PWR out and Logic Level etc), since the laptop in use was rather mature, it was worth confirming that an old driver version was not invoked in error.

Here is a précis of the steps (kindly provided by Remco K. ) to activate a current driver version:

  • Uninstall all versions of the FTDI driver under "Ports (COM & LPT)" (with the option checked 'Delete the driver for this device' enabled).
  • When complete, click "Scan for hardware changes" in the "Action" menu.
  • If the device re-appears again without having to install a new driver, repeat this step until it doesn't. Or until the 'Delete driver' check mark is not there.
  • Uninstall "USB Composite device" or "USB Serial Converter" under "USB Serial Bus-controllers", the same way as described above.
  • When ready, install a fresh copy of the FTDI driver from the FTDI site that matches the OS version by following the documentation provided there.
  • Reboot your system whether it asks you or not.

Fixed! (The exact details will vary of course with the Windows version involved.)


Replies (12)

BUB III JeeNode Zero v4 problems - Added by plutonomore about 2 months ago

Hi,

Recently I purchased a JeeNode Zero vers 4 and BUB III, to play with the Zero's FORTH. Unfortunately
I have run into problems and am hoping someone reading this blog who has SUCCESSFULLY used this
combination can steer me in the right direction.

I have installed Folie 2.11. Am using Windows . USB micro B cable is definitely data not just power.
USB Serial Port COM 10. Driver Provider FTDI. Driver Date 9/03/2016. Driver Version 2.12.16.0 .

When USB BUB III with attached JeeNode Zero is plugged into the COM 10 port the JeeNode Zero
PA 8 (LED) illuminates and the RED Tx LED on the BUB III is illuminated slightly. On opening the Folie 2.11
screen I am asked to enter a choice of COM ports. I enter 3(COM 10) and am greeted with [connected to COM 10]
and the JeeNode LED turns OFF. Enter ! help and get the expected command summary. Enter ! reset but
NO Mecrisp message, terminal just hangs. Hit control D to exit Folie and the JeeNode Zero LED comes ON again.

Have carried out the driver uninstall reinstall procedure outlined previously on this forum for the USB BUB II and
JeeNode Zero but using the USB BUB III this time.

If all COM port settings etc. which result in a successfull connection could be supplied, this certainly would be
of help.

Any help from someone who has successfully got the USB BUB III and JeeNode Zero working on their
Windows system would be greatly appreciated ... sure this would be of help to others as well!

    cheers,

        Matt.

RE: Resolving Windows driver issues talking to the BUB - Added by JohnO about 2 months ago

Hi Matt, good to hear from you again.
I don't have your setup and don't do Forth. I have however played with Folie and Forth. I wonder if your JNZ4 has firmware loaded, have you tried to upload code using the Folie command "!u 6" ?

RE: Resolving Windows driver issues talking to the BUB - Added by jcw about 2 months ago

Are you starting Folie with the -r flag? (i.e. raw mode i.s.o. the default Telnet mode)

RE: Resolving Windows driver issues talking to the BUB - Added by plutonomore about 2 months ago

Hi guys, thanks for the replies.

John, I can't talk to the JNZ and consequently when I key in the !u 6 command I get perpetual display of ....................

JCW, yes I'm launching folie using the -r flag

    cheers,
        Matt.

RE: Resolving Windows driver issues talking to the BUB - Added by JohnO about 2 months ago

I believe the latest BUB III from Jeelabs was tweaked to provide the reset using the FTDI CTS pin - did your BUB III come from digitalsmarties?

RE: Resolving Windows driver issues talking to the BUB - Added by jcw about 2 months ago

FWIW, here's some info about how uploads work and what is needed: http://jeelabs.org/book/1507a/

Update: ehm, except that for STM32 µCs, the RTS pin works the other way around ...

RE: Resolving Windows driver issues talking to the BUB - Added by plutonomore about 2 months ago

Hi guys, once again thanks for the interest and replies.

John, yes both the BUB III and JNZ v4 were purchased from Digital Smarties UK ... sure they enjoyed their trip to the antipodes!

JCW, concerning the upload info you provided, all information is good information ... thanks.

If anyone reading this forum commentary has got the JNZ v4 and BUB III combination working using Folie v 2.11, in a
Windows environment (I'm using Win 7), could they please confirm this. This way I can confirm that, as I suspect the
problem lies with me?

Purchased one JNZ v4 with the intention of constructing a second radio pair THC unit ... a moment of insanity. Anyway
attaching a couple of pix. If I get this thing, working will probably submit a write-up.

    cheers,

        Matt.

JNZv4_THC_bottom
JNZv4_THC_top

JNZ_vers_4_THC_bottom.jpg View - JNZv4_THC_bottom (342 KB)

JNZ_vers_4_THC_top.jpg View - JNZv4_THC_top (407 KB)

2606
2607

RE: Resolving Windows driver issues talking to the BUB - Added by JohnO about 2 months ago

Nice work Matt. I am puzzled by the trouble you are having with the JNZ4 and the USB III. The BUB should work with old style FTDI Jeenodes, I wonder if you have tested this. Similarly, if the firmware on the JNZ4 is intact it should be possible to talk to the Forth code using a standard terminal emulator and an old style BUB.

I hope my responding is not putting anyone with the relevant hardware from sharing their experiences.

RE: Resolving Windows driver issues talking to the BUB - Added by JohnO about 2 months ago

Sending a "." should trigger a response:

42 Stack underflow

RE: Resolving Windows driver issues talking to the BUB - Added by jcw about 1 month ago

Mea culpa.

Just found out that I messed up DTR pin handling in Folie v2.11's raw mode (I mostly use SerPlus myself). I've release a new v2.12 build with a fix for this. This affects all platforms, in raw mode, i.e. with the -r flag. Please try again with the new builds - see https://github.com/jeelabs/folie/releases/tag/v2.12

My apologies for wasting your time if you've been trying out Folie with a BUB III, modified BUB, or similar.

PS. I've only tested on MacOS and Linux.

RE: Resolving Windows driver issues talking to the BUB - Added by plutonomore about 1 month ago

Hi all,

I am happy to confirm that I have just "SUCCESSFULLY" tested the JNZ vers 4 and BUB III combination using Folie 2.12 , in a
Windows 7 environment ... my apologies for the delay in responding but have had a pretty busy week.

John, thanks for your interest and comments.

JCW, thanks for taking the time and making the effort to trace the DTR polarity bug in Folie 2.11 and supply a functioning fix
in Folie 2.12 ... impressive support!

Attaching a screen capture of Folie 2.12 in action, as confirmation.

    cheers,

        Matt.

    (1-12/12)