Cutting the cord, sort of

Added by Diggory_Venn about 3 years ago


First post; and after a few problems I completed the steps to finish the blog entry 'Cutting the cord'. The 'sort of' for me was unsoldering the target board resistor, then I could get things working. I have seen lots of those 'dots', but when it works it goes like lightning.

Other oddities I experienced, were back in "USB serial is a good way to go", I could not get my first SerPlus board to load with folie, but you gave a solution with which worked. My target board didn't work either but that was probably poor workmanship. I then got very thin wire, and made up a new Serplus and a new target, but the new SerPlus board could not be loaded with either folie or stm32loader. I was going backwards! But you gave a solution, a SerPlus could load a SerPlus, and with jumpers, it can, so my new recalcitrant SerPlus board was loaded with SerPlus software, using my original one. Finally when I unsoldered the target board, boot0 resistor, I got usbserial.hex loaded and Mecrisp forth and your extra .fs's with my new SerPlus board; resulting in the final most welcome "hello" message. Fantastic!
So no question, I am merely one of many following what you are doing. So a late, but sincere, happy new year! ...and now, some Forth, and the JNZ posts.

Replies (1)

RE: Cutting the cord, sort of - Added by jcw about 3 years ago

Thank you for posting (and welcome!). Nothing beats hearing about how things are actually working out in The Real World.

I've been seeing a number of different failure modes with boot loader uploads. I'm not quite sure what to make of it - maybe there's an issue with the first byte sent, which the boot loader uses to auto-detect the baudrate. Once that happens, it seems that uploads never get started - maybe Folie should do a reset every so often while trying to get that first synch right.

The other issue I run into sometimes, is that it works perfectly fine, but only after a manual reset (while dots are being printed by Folie) - I see this once in a while with the F103-based Blue Pill boards. On the JNZ with the L053, I don't think I ever have an issue with uploads - which is fortunate because there is no reset button. Ctrl-C has become second nature for me by now, to reset a board hooked up via a SerPlus - very convenient, i.e. not having to reach over at all.

As a general note for whoever is reading this: to try and get a handle on these unsolved glitches, may I suggest adding new issues or commenting on related ones on the Folie issue tracker on GitHub? It's the best way to collect all the information in one place - eventually, I hope we can nail all the problems and make things a smoother experience for first-time users.