Project

General

Profile

Interference on the RFM12B

Added by Rawbear over 7 years ago

I’m using Jeenodes to send and receive information. I noticed that several messages were not received. I loaded the DEMO sketch and set the group to 0, deactivated the filter (0 q). Lots of invalid packets! So much that the real packets often got lost. While testing, I used a separate Arduino (duemilanove) with a separate RFM12B board. That one worked just fine if placed away from the computer (the USB cable is 1 meter long). Valid data was coming in with very little interference.
I tested with other boards (ladyada, Arduino Uno) and had very few bad packets. But every time I tried a Jeenode (standard V6, SMD) most of the traffic was parasitic. I thought the FTDI card might be the problem, but the same card on the ladyada boarduino is working fine.

What could make a difference in the way the Jeenode is setup, that would cause it to be so sensitive to interference?


Replies (4)

RE: Interference on the RFM12B - Added by JohnO over 7 years ago

Did you configure the other Arduino’s with group 0 and no filtering and run the DEMO sketch?

RE: Interference on the RFM12B - Added by Rawbear over 7 years ago

Yes I did. And the non-jeenode boards were using the same rfm12b board. I also tried using different FTDI boards.

RE: Interference on the RFM12B - Added by JCee over 7 years ago

Hi,

It could be that it is your website ;) but the same problem is reported here as well: http://practicalusage.com/?p=775
Edit: looking at the date of the posts it probably is LoL.

RE: Interference on the RFM12B - Added by Rawbear over 7 years ago

Ya, it’s me :)

    (1-4/4)