Project

General

Profile

Stuck without USB-BUB but have mySmartUSB MK2 v2.5

Added by Till about 6 years ago

Hi there!

First post :-)

I’ve bought two JeeNodes a few years back (v3!) and got them out this Monday. But now I’m in Chile and therefore cut off from fast deliveries otherwise I’d just get a USB-BUB.

But I do have a mySmartUSB MK2 and got it to write the Blink example sketch on the JeeNode. I had to use the ISP header to do it and the LED blinks fine.

Now I’d like to communicate with the JeeNode as in the RF12demo. The sketch compiled and was written to the JeeNode. From what I understood it’s rather simple with the USB-BOB and it seems to use the FTDI connector (Tx, Rx, Res, Pwr, Gnd). The mySmartUSB can be forced to data-mode (UART-USB-Bridge) with dip-switches. But the Arduino Serial Monitor shows nothing at all.

I’ve hooked it up to the JeeNode like this:

JN FTDI Pin on mySmartUSB
—————————
RTS —> (6) reset board
TX —> (7) TxD PC (USB-UART-Bridge)
RX —> (8) RxD PC (USB-UART-Bridge)
PWX —> (9) VCC
GND —> (10) GND

I’m confused by the Tx/Rx on the JeeNode. It seems that “Rx” (next to RST) is connected to pin 3 of the MC, which is “PD1/TXD” according to its datasheet. I’ve swapped Tx and Rx but that didn’t work either…

Help?!

Thanks
Till


Replies (7)

RE: Stuck without USB-BUB but have mySmartUSB MK2 v2.5 - Added by ozzy about 6 years ago

If you can download to the JeeNode then your BUB most be working. Have you looked at the baud rate setting in the monitor, I think it’s 57600.

RE: Stuck without USB-BUB but have mySmartUSB MK2 v2.5 - Added by JohnO about 6 years ago

He says he used the ISP headers to program it.

RE: Stuck without USB-BUB but have mySmartUSB MK2 v2.5 - Added by Till about 6 years ago

Thanks for the baudrate hint. Now it’s at least giving me data garbage. Guess that’s progress:

? 49 99 76 139 42 26 185 62 7 133 83 0 144 238 143 199 165 111 44 92 254
? 6 151 218 207 29 45 124 73 121 215 208 94 255 48 8 99 71 109 63 255 139
? 48 64 113

Should I swap Rx and Tx again? Now the ATMega Pin 3 / PD1 / TXD is connected to “RxD PC (USB-UART-Bridge)” - as I said, confusingly, via the “Rx” pin of the FTDI header.

RE: Stuck without USB-BUB but have mySmartUSB MK2 v2.5 - Added by JohnO about 6 years ago

That’s looking good, TX & RX are as they should be - now you need to get another JeeNode transmitting to it.

RE: Stuck without USB-BUB but have mySmartUSB MK2 v2.5 - Added by JohnO about 6 years ago

I guess if you keyed in a “?” you would see the actual settings - may need adjusting to the correct frequency for your hardware, also group and node number.

RE: Stuck without USB-BUB but have mySmartUSB MK2 v2.5 - Added by JohnO about 6 years ago

Perhaps load RadioBlip2 into your other JeeNode, the sketch is default 868MHZ - I’m not sure about your hardware. Just make sure you set them up compatibly. Then with your async terminal you should see some “OK” packets.

RE: Stuck without USB-BUB but have mySmartUSB MK2 v2.5 - Added by Till about 6 years ago

It’s working now! I did two things and I’m not sure what did it:

1) Changed the baud rate to 19200 in rf12demo and on the serial monitor
2) Actually typed something (just an “x”)! As a reply I got the menu and could turn the LED on and off.

Will get the second JeeNode ready now. Thanks for the help

    (1-7/7)