Project

General

Profile

Unable to program ATTiny > 4kb

Added by wolfpackmars2 over 5 years ago

So… I seem to have run into the problem referenced here:
http://forum.arduino.cc/index.php?topic=116674.0
and here:
https://code.google.com/p/arduino-tiny/issues/detail?id=58

I’m about 1 byte over the limit apparently. Has anyone else run into this? The suggested fixes from the two links above seem onerous - there must be a more straightforward fix?


Replies (3)

RE: Unable to program ATTiny > 4kb - Added by wolfpackmars2 over 5 years ago

commenting out a couple of semi-optional if statements has resolved it - for now…

RE: Unable to program ATTiny > 4kb - Added by JohnO over 5 years ago

Are you Win/Mac or Linux?

RE: Unable to program ATTiny > 4kb - Added by JohnO over 5 years ago

The solution I evolved for Windows works and is published here http://jeelabs.net/projects/hardware/wiki/JeeNode\_Micro I believe that jcw has used a similar approach on a MAC.

Setting up the Tool Chain on Windows

Download the latest WinAVR. http://sourceforge.net/projects/winavr/files/WinAVR/20100110/
Install the latest WinAVR to a convenient location. For example at C:.
Check that the Arduino IDE is not running.
Locate the existing tool-chain directory. It should be in {ArduinoRootFolder}\hardware\tools.
There should be a single sub-directory there named avr. Rename this to something like avr_old.
Create a new sub-directory named avr.
Move the entire contents of the WinAVR directory (C:) to the newly created avr directory ({ArduinoRootFolder}\hardware\tools\avr).
Check that subdirectory {ArduinoRootFolder}\hardware\tools\avr\etc is present. Create etc if not present.
Copy avrdude.conf from {ArduinoRootFolder}\hardware\tools\avr\bin to {ArduinoRootFolder}\hardware\tools\avr\etc

The Arduino IDE should now run and build sketches. If there are problems, switch back to the original tool-chain by renaming avr to avr_new, then renaming avr_old to avr.

    (1-3/3)