Project

General

Profile

RFM12B Diagnostic sketch?

Added by Okachobi almost 5 years ago

I wrote some home automation code that makes use of various jeenodes (available via https://code.google.com/p/arduino-aaser-gateway/ - apologies for the bug that I’ve yet to patch in the LEDNode sketch) and got it all working with an Amazon Echo and the Echo Bridge project (https://github.com/armzilla/amazon-echo-ha-bridge). So I’m able to command my LED lights via voice with the Amazon Echo- it works great. I don’t have instructions up yet on how to do it, but the short of it is to run the lightgw.py script, use the LEDNode.ino on your LEDNode (I need to commit the fixed version that include EEPROM and defines the lastupdate variable) and flash your JeeLink with the LEDGateway.ino, run the echo bridge and make a JSON request to it using CURL to feed in the On/Off URL for lightgw.py for the device ID of your LED Node. When I get more units working I plan to migrate the code to github, fix the bug, and post a writeup on using it with the Amazon Echo.

So I needed to add more lights to fully test and purchased another Jeelabs LEDNode from ModernDevice. I assembled it the same way as the other LEDNode and loaded my sketch but it doesn’t hear the Master broadcast from the Jeelink. I double-checked the radio to make sure it was 434Mhz (and it was- green dot) but it still didn’t work. I’ve rechecked every solder joint and found no bridges. I even reflowed the solder on the RFM12B radio to make sure there were no bad solder joints between it and the board (it was pre-soldered). That didn’t work either. Then I thought perhaps the ATMega had a bad pin, so I swapped the ATMega with the working unit that I had already built- and the new unit still doesn’t work. So the same micro that was on the working unit did not work on the new unit, therefore it wasn’t a sketch issue.

I’ve spent hours now checking and rechecking everything and tested the socket traces with a multimeter to make sure they were all connecting to the RFM12B. I have found nothing wrong- no solder bridges…nothing. The board revisions on the working one and the non-working one are both LED Node v2a.

I’m using the RFM12B library and not jeelib. When I started work on this, jeelib wasn’t quite as good as the rfm12b library and didn’t support encryption. I’m not sure if it does now, but I had no reason to change once I got it all working. But, the code was working fine- and still works fine with the other LEDNode I have.

Is there any sketch or trick to get diagnostics to make sure the RFM12B is working? It passes the RFM12B::Initialize call, and when I run it with the working hardware, I see the broadcasts from the Master Node.

I always use a grounding strap when working, so I don’t believe this was a static discharge issue. I’m starting to think I got a bad unit or that the Radio, while marked with a Green dot, is not the 434Mhz radio. I’ve contacted ModernDevice.com to see if it might be possible to do an exchange but got no response from their support email. I’ve bought a few hundred dollars worth of stuff from them at this point and didn’t complain when the kits were missing pieces I already had, so I would hope they would swap a \$30 unit…but it would be nice just to get a response :-(

I’d rather find the issue than return it, so any help anyone can provide would be appreciated.


Replies (5)

RE: RFM12B Diagnostic sketch? - Added by JohnO almost 5 years ago

Could you perhaps try loading RF12Demo from the examples directory of jeelib. From there you could attempt to send test packets to another Jeenode. Could you post a photograph of the problem node, I am pondering if your node might be equipped with RFM69CW hardware rather than RFM12B.

RE: RFM12B Diagnostic sketch? - Added by martynj almost 5 years ago

@Okachobi,

Do you have access to a ’scope? You can do a limited RF module check out with your multimeter - measure the current taken by the board in idle, receive and transmit.
These are the expected values

RE: RFM12B Diagnostic sketch? - Added by Okachobi almost 5 years ago

I don’t have easy access to a scope but will try measuring the power draw. During testing I’ve generally got it tethered to a computer via an FYI cable and drawing power from it, so it could be tricky. My multimeter doesn’t have a hold function either :-( I might be able to use my bus pirate on it to sniff the activity. At \$30 though, I’m not sure how much time it’s worth. I’ve considered just ordering the \$6 radio and replacing it. I’ve wasted more than \$30 of time trying to find the problem already but it would be rewarding to fix it. Moderndevice.com appears to have a \$6 return/fix charge, but I’d have to ship it back to them.

The attached image is the radio. As far as I can tell, it’s identical to the other led node I have.

image.jpg (812 KB) image.jpg Led node radio
image_ll.jpg (179 KB) image_ll.jpg
2336
2337

RE: RFM12B Diagnostic sketch? - Added by pbadger almost 5 years ago

> Okachobi,

If you’ve got a weak radio we’ll be glad to replace it for free.
Send us your address and we’ll send one out.

It’s a tad tricky replacing a radio though - you really need a hot air gun, and even then it’s really easy to end up lifting one of the important pads on the pcb.
Just go very slowly. You might be better off sending back the board for us to fix.

Paul Badger
Modern Device

RE: RFM12B Diagnostic sketch? - Added by martynj almost 5 years ago

Okachobi,

The photo confirms a 434 MHz unit is installed. The SPI bus is accessible on that 2x3 group of pads to the left if you want to debug this further - but the limited evidence so far is pointing to infant mortality of the RF Module.

    (1-5/5)