Blocking rf12_ commands

Added by danst0 about 4 years ago

Dear all,

I just bought two JeeNode v6 (and one Jeenode USB). I tried to run the current, stock version of roomNode. The program seems to be stuck at the rf12_sleep command in the setup routine.

rf12_sleep(RF12_SLEEP); // power down

So I see the "before" but not the second "after" on the serial console.
It does work well on the JeeNode USB but on neither of my JeeNodes v6.

As an addon: I commented all rf12_sleeps out. Now it hangs at rf12_lowbat.
There seems to be a communication problem with the RF12.
I do not find any shorts on the module connections

I am using ARDUINO IDE 1.6.8 (latest version).

I did not find anything helpful in the forum or wiki. Could anyone please help me out?


Replies (6)

RE: Blocking rf12_ commands - Added by martynj about 4 years ago


I suggest you fall back to Arduino IDE 1.0.6 - there are some reports of SPI problems with 1.6.8
Is the JeeNode USB still running the original rf12 image supplied?

RE: Blocking rf12_ commands - Added by danst0 about 4 years ago

The JeeNode USB was programmed with the roomNode software as well (and worked).

I tired the 1.0.6, however with the same result. The roomNode hangs at rf12_sleep(RF12_SLEEP); // power down


RE: Blocking rf12_ commands - Added by danst0 about 4 years ago

Might there be any other configuration step in the drivers that I missed? The connections between RF12 and the ATMega seem to be ok.
Why doesn't it work for both brand-new JeeNodes?

RE: Blocking rf12_ commands - Added by mvdswaluw almost 4 years ago

danst0 Did you add a solder blob on the spot between pwr and the regulator (top left bottom side in your picture)? If not the Jeenode is running on parasitic power and might behave strange.

RE: Blocking rf12_ commands - Added by martynj almost 4 years ago


Worth checking the suggestion from mvdswaluw, but the default is the bridging pads under the not-needed D1 are normally linked by a cuttable trace. Perhaps also check the fuse settings between the JeeNodes and the JeeNode USB - you can read them out with AVRDude.

RE: Blocking rf12_ commands - Added by danst0 almost 4 years ago

mvdswaluw: There is a connection between PWR and one of the regulator pins (top right in bottom side picture) however this is supposed to be?

Now I reflashed the original firmware (rf12demo) and then I adapted the node ID and group ID. Then I tested it between two rf12demo firmwares. It finally works!

So it seems that there was only some initial configuration missing?
Please let me know if you have any idea why it hung at this function in the first place?