nrfmon no Hw ID error

Added by haeleng over 1 year ago


I like to do some range tests with RF12b modules integrated on some the JeeNode USB devices I have.
I red that this could be done with the specrumanalyser implemented in the nrfMon software which runs on a Windows 10 computer.
I downloaded from github the nrfmon files.
For making a scan I downloaded the nrfmon.ino sketch to a JeeNode USB device, which is on serial port Com6
I run the executable on a Windows 10 computer from the binaries directory called nrfmon.exe
From here I select Com Port 6.
I get an error: error reading "file574f8a0": I/O error
In the source file there is a comment with
Change the last part in the next line to reflect the hardware signature that'll be shown on the RfMon screen.
The signature is a dictionary, i.e. should be pairs of key/value, where the last pair is the hardware type
#define RFMON_SIGNATURE F("xcvr rf12b ver 0.7.6 hw JeeNode.v6")

I do not understand what this means
What am I doing wrong. Why do I not get a connection.
Please help

Replies (5)

RE: nrfmon no Hw ID error - Added by JohnO over 1 year ago

I am not aware that nrfMon has been run on Win10. It just worked for me on Win7, it's been a while though.

RE: nrfmon no Hw ID error - Added by martynj over 1 year ago


It would indeed be interesting to get nrfmon running under Windows 10 - as well as the RSSI levels of your received packets, this will show graphically other activity in that portion of the spectrum. For example, you can see the effective noise floor and may see an interferer transmission close to the channel in use - if so, there may be extra range available just by shifting the channel in use to a "quieter" part of the band.
If you are just interested in the RSSI readings, an alternative path is to monitor the traffic with rf12demo running on a node using an RFM69CW radio module - this will see all the RFM12B packet traffic and report the RSSI values. Pre-assembled JeeNodes have rf12demo as the default install - it is used as the last QA check before shipment.

RE: nrfmon no Hw ID error - Added by JohnO over 1 year ago

I have just tried to set up nrfmon on my old Win7 machine and am having difficulties. I get connected to the the Jeelink running rf12mon then after a few seconds it disconnects. I will investigate further.

RE: nrfmon no Hw ID error - Added by haeleng over 1 year ago

Hi John,

Thanks. I have the same problem with the Win10 machine as mention at the beginning of this topic.
I also checked it on an old XP machine and run into the same problem.
Connects for a few seconds and disconnects with an error message.

RE: nrfmon no Hw ID error - Added by JohnO over 1 year ago

It used to work for me on my Win7 machine - I wonder if MS or TCL have changed something. Dzach is a really nice chap, he may be prepared to take a look.